Trying to generate a report in my application and getting the below validation error -
Error in deserializing body of reply message for operation 'ExecuteReport'
When I debugged, the execution was failing on ExecuteReport Service method

asked 16 Oct, 12:01

Nitin%20Chhabra's gravatar image

Nitin Chhabra
101222529
accept rate: 33%


This is due to the fact that only part of XML response for the report was getting returned and deserialized and failed. You can resolve the issue by manually updating the binding configuration for Graphite Reporting Service (BasicHttpBinding_ISqlServerReporting) has maxBufferSize, maxReceivedMessageSize, maxStringContentLength set to 65536.

<binding name="BasicHttpBinding_ISqlServerReporting" closetimeout="00:01:00" opentimeout="00:01:00" receivetimeout="00:10:00" sendtimeout="00:01:00" allowcookies="false" bypassproxyonlocal="false" hostnamecomparisonmode="StrongWildcard" maxbuffersize="65536" maxbufferpoolsize="524288" maxreceivedmessagesize="65536" messageencoding="Text" textencoding="utf-8" transfermode="Buffered" usedefaultwebproxy="true"> <readerquotas maxdepth="32" maxstringcontentlength="8192" maxarraylength="16384" maxbytesperread="4096" maxnametablecharcount="16384"/> ... </binding>

To resolve this issue: Changes have to be made to the web.config of the deployed application (in the inetpub folder). Response limits have to be updated to 2147483647 (maxint) for the following:
1. maxBufferSize
2. maxReceivedMessageSize
3. maxStringContentLength

<binding name="BasicHttpBinding_ISqlServerReporting" closetimeout="00:01:00" opentimeout="00:01:00" receivetimeout="00:10:00" sendtimeout="00:01:00" allowcookies="false" bypassproxyonlocal="false" hostnamecomparisonmode="StrongWildcard" maxbuffersize="2147483647" maxbufferpoolsize="524288" maxreceivedmessagesize="2147483647" messageencoding="Text" textencoding="utf-8" transfermode="Buffered" usedefaultwebproxy="true"> <readerquotas maxdepth="32" maxstringcontentlength="2147483647" maxarraylength="16384" maxbytesperread="4096" maxnametablecharcount="16384"/> ... </binding>

Updating the Response limits should let the report show up in the application.

CAUTION: The web.config will revert to default values every time a project is built in Graphite studio.

NOTE: A future version of Graphite Studio will allow specifying these settings in Environment settings.

link

answered 16 Oct, 12:29

Nitin%20Chhabra's gravatar image

Nitin Chhabra
101222529
accept rate: 33%

edited 16 Oct, 12:30

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×4
×3
×1
×1

Asked: 16 Oct, 12:01

Seen: 39 times

Last updated: 16 Oct, 12:30

Powered By:   Graphite